Hướng dẫn mã hóa DNS với NextDNS chi tiết

26
  • Dạo gần đây, DNS đang là chủ đề đang chú ý bởi tính riêng tư của DNS. Và bài viết này nhằm mục đích mọi người nâng cao bảo mật bằng cách chuyển dần sang sử dụng DNS mã hóa.

  • Sử dụng DNS native sẽ không cần thay đổi DNS mỗi khi đổi mạng Wifi, kể cả trên di động sử dụng 3/4G đều không cần lo lắng phải tìm cách đổi DNS.

Tham khảo:

Tính năng của NextDNS

  • Đã có máy chủ tại Việt Nam, khi sử dụng DNS mã hóa.

  • Có 132 máy chủ đặt khắp nơi, dù ở bất kỳ đâu cũng kết nối máy chủ ở quốc gia đó/hoặc gần đó.

  • Vừa là DNS công cộng bên thứ 3, không ảnh hưởng bất kỳ ai và hoàn toàn miễn phí.

  • Vừa là DNS riêng tư, khi đăng ký/trả phí với các tính năng nâng cao như chặn theo dõi/qc, mã độc, giúp phụ huynh quản lý truy cập của con/em/cháu theo thời gian biểu.

  • Được Firefox thông báo đối tác mới trong việc cung cấp dịch vụ DNS riêng tư và bảo mật cho người dùng. https://blog.mozilla.org/en/mozilla/firefox-announces-new-partner-in-delivering-private-and-secure-dns-services-to-users/

Hướng dẫn trên trình duyệt

Trình duyệt trên PC hầu hết đều hỗ trợ addon chặn qc nên chỉ cần sử dụng DNS public là đủ.

ĐỐI VỚI TRÌNH DUYỆT CHROME/CHROMIUM

  • Vào Cài đặt > chọn Riêng tư và Bảo mật > chọn Bảo mật ở bên phải > tìm đến dòng Sử dụng DNS an toàn > tick chọn dòng Với > chọn NextDNS ở hộp thoại kết bên.

Lưu ý:

  • Phải tick chọn mới có tác dụng.

  • 1 số máy sẽ không có NextDNS, chỉ cần chọn Tùy chỉnh và thêm https://dns.nextdns.io là được.

ĐỐI VỚI TRÌNH DUYỆT FIREFOX

  • Vào Cài đặt > cuộn xuống phía dưới phần Cài đặt mạng > nhấn Cài đặt > tick chọn ô Kích hoạt DNS over HTTPS > chọn NextDNS ở menu bên dưới > nhấn OK lưu lại.

Hướng dẫn trên điện thoại

Khi sử dụng NextDNS trên điện thoại cũng có thể chặn inapps nếu dùng ID đăng ký riêng

Tất tần tật về cách tạo NextDNS https://voz.vn/t/tat-tan-tat-ve-dich-vu-nextdns.522718/

ĐỐI VỚI IOS 14 TRỞ LÊN

ĐỐI VỚI ANDROID 9 TRỞ LÊN

  • Vào Cài đặt > Mạng & internet > Nâng cáo (hoặc Cài đặt mạng khác) > DNS riêng tư > chuyển từ Tự động sang Thủ công > Điền fd88ba.dns.nextdns.io và Lưu lại.

  • Nếu muốn sử dụng NextDNS public chỉ cần điền dns.nextdns.io

ĐỐI VỚI IOS VÀ ANDROID CŨ HƠN

Sử dụng app để mã hóa DNS

Hướng dẫn trên router

Các router nhà mạng cung cấp miễn phí không có DNS mã hóa, nên chuyển sang DNS mã hóa ở từng thiết bị để sử dụng server ultralow

OPENWRT

  • Cài đặt và sử dụng gói https-dns-proxy có sẵn và trình điều khiển trên web

opkg update
opkg install https-dns-proxy
opkg install luci-app-https-dns-proxy
/etc/init.d/rpcd restart
  • Chạy lệnh bên dưới để thay đổi thành NextDNS public, thêm ID phía sau nếu muốn sử dụng ID riêng để lọc qc

while uci -q delete https-dns-proxy.@https-dns-proxy[0]; do :; done
uci set https-dns-proxy.dns="https-dns-proxy"
uci set https-dns-proxy.dns.bootstrap_dns="45.90.28.0,45.90.30.0"
uci set https-dns-proxy.dns.resolver_url="https://dns.nextdns.io"
uci set https-dns-proxy.dns.listen_addr="127.0.0.1"
uci set https-dns-proxy.dns.listen_port="5053"
uci commit https-dns-proxy
/etc/init.d/https-dns-proxy restart

MERLIN FOR ASUS

Router sử dụng IP cố định, bạn nên thường xuyên kiểm tra địa chỉ IP server ultralow và sửa lại nếu có thay đổi

  • Truy cập vào mục WAN > Internet Connection > di chuyển tới phần WAN DNS Setting

  • Kiểm tra các mục dưới đây đã chọn đúng

Connect to DNS Server automatically: NO
Forward local domain queries to upstream: YES
DNS Privacy Protocol: DNS-over-TLS (DoT)
  • Truy cập https://router.nextdns.io/?limit=10&stack=dual và ghi lại 2 địa chỉ IP server có tên -han-. Hiện tại, có 2 server là greencloud-han có IP là 103.199.17.192 và anexia-han có IP là 203.162.172.59

  • Tại phần DNS-over-TLS server list, điền lần lượt

Ô Address điền 2 IP ở trên
Ô TLS điền 853
Ô TLS Hostname dns.nextdns.io hoặc có ID thì điền <ID>.dns.nextdns.io

MIKROTIK

Router sử dụng IP cố định, bạn nên thường xuyên kiểm tra địa chỉ IP server ultralow và sửa lại nếu có thay đổi

  • Truy cập Truy cập https://router.nextdns.io/?limit=10&stack=dual và ghi lại 2 địa chỉ IP server có tên -han-. Hiện tại, có 2 server là greencloud-han có IP là 103.199.17.192 và anexia-han có IP là 203.162.172.59

  • Chạy lệnh bên dưới để thay đổi thành NextDNS public, thêm ID phía sau nếu muốn sử dụng ID riêng để lọc qc

/tool fetch url=https://curl.se/ca/cacert.pem
/certificate import file-name=cacert.pem
/ip dns set servers=
/ip dns static add name=dns.nextdns.io address=103.199.17.192 type=A
/ip dns static add name=dns.nextdns.io address=203.162.172.59 type=A
/ip dns set use-doh-server=“https://dns.nextdns.io/" verify-doh-cert=yes

Kiểm tra

Lưu ý

  • Các bộ lọc đang sử dụng của ID fd88ba là NextDNS Ads & Trackers Blocklist, AdGuard DNS filter và hostsVN

  • Link aff để mọi người ủng hộ ID chia sẻ ở trên https://nextdns.io/?from=nxyre65e

  • Đăng ký ID miễn phí sẽ có giới hạn 300.000 truy vấn/tháng, reset vào đầu tháng, khi đạt giới hạn NextDNS vẫn phân giải bình thường không gây rớt mạng.

  • Giá 45.000đ/tháng và 450.000đ/năm. Fake IP sang Thổ Nhỉ Kỳ mua chỉ có giá 180.000đ/năm thôi!

(Nguồn Jerry Nguyễn – Group J2TEAM)